Answered By: KRS Archive
Last Updated: Oct 21, 2020     Views: 1469

Our website and many of our licensed resources have minimum web browser requirements to ensure that all the features and functionality are available to you. As Internet Explorer is no longer being supported by Microsoft, it no longer meets the browser requirements used by our vendors. We recommend that you use the latest version of Edge, Firefox, or Chrome to ensure that you have the best experience.

If you are having trouble accessing the KRS website or resources, we encourage you to contact the IT Service Desk to determine if Edge would be appropriate in your circumstance.

If you are using an up-to-date version of a browser and still experiencing issues, we recommend that you clear your web browser's cache. We often find that this simple step resolves many reported issues and can have you back on your way to using our website and resources. Please ask one of our staff members if you need assistance -- we are happy to help.

Related Topics

Chat with KRS