Answered By: KRS Archive
Last Updated: Feb 06, 2015     Views: 55

The minimum requirements to use the EBSCO resources (CINAHL database, Business Source Complete, various full-text article journals) and Pubmed is Internet Explorer 7.0 or later.

If you are not sure which browser version is running on your computer and your library computers, click on this link and the site will generate the information for you.

If computers at your location are using a version lower than IE8, please contact your AHS-IT Service Desk and request the upgrades as soon as possible. 

Related Topics

Chat with KRS